Select a topic:

Choose from one of the topics below to browse other articles

Help Guides & Frequently Asked Questions

What are the technical requirements for using iAM?

iAM is available anywhere that you have an Internet connection and a modern web browser (IE 9+, Safari, Chrome, Firefox).  There's nothing to install and no hardware requirements.

If you have an older version of Internet Explorer then unfortunately you will not be able to use iAM.  Versions older than 9 are no longer supported by Microsoft and we highly recommend that you upgrade.

Last updated by Laura Smith on May 18, 2017 14:21